PhpStorm with git automatically adds/stages removed and moved files

How do I stop PhpStorm from doing that?
I just accidentally committed a file move when I was not supposed to.
I hate this, I don't want PhpStorm to automatically do these kinds of things for me.
Couldn't find anything on this, only answer on Google has different options under Version Control than my PhpStorm.

I'm using PhpStorm 9.0.2.

6 comments
Comment actions Permalink

What settings are chosen in Settings | Version Control | Confirmation? Do you have 'Add silently' and 'Remove silently' enabled?

0
Comment actions Permalink

hmm.. Can you, please, describe your issue in details? What are you doing exactly, what is the file status before and after these actions, etc.?

0
Comment actions Permalink

I click on a file in the tree. Ctrl+X. I click on a directory in the tree that is not the same one as the file is in. Ctrl+V. In the popup the checkboxes are unticked and I click on OK.
The file is now moved to a new directory and git status shows that this move has been staged. Before that, git status was that nothing has changed.

It may be relevant that the image I posted was taken after I changed these settings. I tried again after changing them, even restarted PhpStorm but the issue remains.

0
Comment actions Permalink

Same issue here (in my case with WebStorm).

With the settings in the screenshot I can prevent WebStorm from automatically staging changed, added or deleted files in git.

Moved or renamed files are still automatically staged, though.

Is there any way to prevent WebStorm (or PhpStorm) from automatically staging moved or renamed files in git (without disabling git completely)?

0

Please sign in to leave a comment.