PhpStorm extremely slow on large source files

Hi guys,

I'm currently evaluating PhpStorm for my daily coding work and I'm totally stunned about it's features and speed (coming from Aptana/Eclipse/Zend Studio).

But there is one really big issue that blurs my oppionion on PhpStorm's speed: Every time I open/edit larger PHP files (i.e. 10K lines of code) PhpStorm becomes more slow than a sloth. I've to wait up to 60 seconds after changing a single character in one of these bigger files.

I've this experience on two machines:

Both have the same software basis: PhpStorm 1.01, Ubuntu 10.4 x64, Sun JRE 6 (6.20dlj-1ubuntu3)

Machine 1 is a Core i7 920, 12GB RAM, machine 2 is AMD Phenom X4 965, 4GB RAM

Configuration has not been changed - I'm experiencing this using out of the box configuration.

Interesting fact: CPU usage and IO wait keep as low as using smaller files - there is nothing suspicious.

What can I do to get more performance on editing larger files?

47 comments
Comment actions Permalink

@Eb Develop I'm looking at chamilo-lms, julitosss described his case quite sufficiently, thank you.

We need logs to detect 3rd party plugins related problems and other crucial info.

The latter is even more true for git annotate problems.

0
Comment actions Permalink

> Me too.

It's you and one other user who talk about Chamilo, other reports are just "me too" with no details, with different setups and projects.
It's impossible to handle this stuff within a single forum thread, that's why we'd better see these requests as support tickets.

As for the Chamilo issue, I've tried Git Annotate - seems to work just fine:
http://recordit.co/CKN12bK3mH
So it's not easily reproducible. Could you please submit a support request with the log attached after PhpStorm restart and issue reproduction?

P.S. While I was typing the reply, Alexey has answered, so I deleted my original comment.
0
Comment actions Permalink

I have found and addressed couple of hotspots after looking at chamilo (will and other cases too).

You'll be able to try it in tomorrow's EAP.

Also, consider an important workaround -> please disable automatic SQL language injection (or better any language injection at all) for big files like learnpath.php Settings->search for "injections"

0
Comment actions Permalink

So I'm not the only one here.

Slowing down on less than 5k line files? Damn, you need to update your computer if your having issues there. I find anything in excess of 50k really hampers performance.  In files with 100k + lines I've had my system hang for a solid 30 minutes.

System specs are:
i7 5820K @ 4Ghz ( Watercooled O/C)
32Gb DDR4 memory
Nvida 1070 GPU ( Running 2x 4K screens)
Samsung 950 Pro 512gb M.2 main drive

0
Comment actions Permalink

Looks like the performance problems still exists and this after years of customer complaints. :/ I gave up to find out what the problem causes... By my experience you can do the following things to reduce lags:

- Restart PHPStorm like every half hour or when it starts getting slowly. Thats what I do to more or less control the laggyness of PHPStorm.
- Best performance boost: Got to "Customize Highlighting Level" (right click on the explanation mark in the upper right corner and check "Power Save Mode". Turn it on when needed in between.

Just my 2 cents

0
Comment actions Permalink

Tayger, we would appreciate if you could try out latest EAP build, capture a CPU snapshot and upload to our FTP per https://intellij-support.jetbrains.com/hc/en-us/articles/207241235-Reporting-performance-problems

0
Comment actions Permalink

Hey guys!

The problem is still on, I've updated to the latest version just today. ATM working with a 8914 line php file with lots of SQL-s and strings in it, and inspection runs forever. I've tried to disable plugins, injections, inspections. The processor is at 100% when inspecting, the little eye icon in the top right corner almost always visible. Sometimes the IDE reports problems they are not there any more, especially when I open/close a new block, or a new case in a switch - maybe it depends on a successful/quick inspection?

I've got good news too; the copy-paste works fine and isn't pasting old data from the clipboard any more :)

0
Comment actions Permalink

Laszlo, have you tried the workaround Alexey suggested?
> please disable automatic SQL language injection (or better any language injection at all) for big files like learnpath.php Settings->search for "injections"

0
Comment actions Permalink

Laszlo, I assume you have the same problem as i have: https://youtrack.jetbrains.com/issue/WEB-28394
It its currently under investigation. 

I guess that the bigger the file is (mine is around 20k lines) the slower it gets. I have completely disabled inspector and third party plugins but still slow. So there might be a very CPU consuming process in the background hurting on a a certain size of file.

Maybe other settings for VmOption might help a bit. 

 

0
Comment actions Permalink

Thanks for the quick reaction guys!

Eugene, I've already tried that workaround, but it didn't solve the problem.

Taygen, thanks for the link, I'm going to try to adjust vmoption settings, as this page suggests: https://www.jetbrains.com/help/phpstorm/tuning-phpstorm.html

0
Comment actions Permalink

Last EAP build of PhpStorm 2017.3 contain critical fixes for typing performance on large files. Please test and report your experience https://confluence.jetbrains.com/display/PhpStorm/PhpStorm+Early+Access+Program

Next one will have several more. We have this now under special test coverage, will take care to avoid any regression in future.

0
Comment actions Permalink

Thank you! I just have tested it out with PHP Storm 2017.3 EAP (Build PS-173.2463.17):  No performance improvements at all so far, stated at: https://youtrack.jetbrains.com/issue/WEB-28394 (initial indexing around 800% of CPU usage).

Let's hope the "final" release will bring some real performance improvements. 

0
Comment actions Permalink

Thank you very much for the effort! I've also tested that build, but didn't noticed any improvements (edited several 8000+ line php files), that few turned-on inspections run for ages. I hope you will find the problem soon. Best wishes.

0
Comment actions Permalink

Hey guys!

Found some clue for the problem. As for me, syntax analysis is the slowest. I've got this info from the popup box clicking on the eye icon in the top right corner. Already turned off almost all not used plug-ins and inspections. After restarting the program, inspections got much quicker, but typing in some chars and doing some modifications, it's slow again. PhpStorm gets unresponsive till it's finished, sometimes even cursor disappears.

Hope this helps to locate the problem.

0
Comment actions Permalink

Exactly same problems as Laszlo

0
Comment actions Permalink

Additional clues:

  • I always keep "Structure" tab open, if I close it, it seemes a bit better, but I desperatly need that tab to be opened
  • the "eye" icon sometimes appears just switching between source tabs
0
Comment actions Permalink

Unfortunately https://youtrack.jetbrains.com/issue/WEB-28394 is clearly JS support issue and must be addressed by other team..

I'll try to help them... Follows up will be in that issue.

Please only continue *here* IF you performance problems persist with JS plugins disabled (Settings|Plugins).

0

Please sign in to leave a comment.