PhpStorm 10 command line tools not interactive on Ubuntu 15.10

Hello,

I'm using PhpStorm 10.0.2 on Ubuntu 15.10 (recently moved from Windows 7). I have started a new Symfony project in PhpStorm and set up Command Line Tools for Symfony. When I run a Symfony command via the Command Line Tools Console that does not require interaction everything works great, however, the problem arises when I run a Symfony command that requires interaction, it simply fails stating such and such is required but did not even prompt for them. In Windows 7 it was working fine so I suspect it is due to some Linux permissions or such.

I've tried to research a solution or workaround and found the point where Symfony sets the interactive mode to false. I tried overriding that and managed to get interaction of sorts but the cursor was not placed correctly and text was output after the question once, it was a little messy but usable. It is completely different when I run the same command via the Terminal within PhpStorm, the whole process works as expected and is neat.

I created a very simple PHP script containing only:

var_dump(posix_isatty(STDIN));

If I run that script via the Terminal in PhpStorm it outputs True, however running it via the Command Line Tools Console it reports False.

Does anyone know how PhpStorm executes the command via the Command Line Tools Console, maybe that will help me investigate further?
Or, Does anyone know of a way in Lunux (or PhpStorm) to enable interactive terminal for the Command Line Tools Console so that it behaves like the Terminal?

Thank you
Mark

Please sign in to leave a comment.