Auto -conversion to HTML elements

I don't know what I did to my PhpStorm installation, but it is awful.  Maybe it came from checking out what Hector does, but I thought I left him in the same state as I found him.  Or maybe it came from updating from 10.0.0 to version 10.0.2? I really Really REALLY want it to stop.

I was editing an HTML file about a tax form and got:

<form action=""></form>

a href="thing it does to you."></a>

I seriously
<object data="to this!" type=""></object>


How do I turn this nonsense off???  Thank you in advance.

2 comments
Comment actions Permalink

Hi there,

It's either Emmet or Live Templates.

You must be using Tab or Enter after entering such word (typical "expand" shortcuts) or completing entries from code completion popup.

If such conversion happens after you use Space then you mast have chosen it as expand key at some point.

I suggest checking what exactly you are doing (at what step such replacement happens -- what key was pressed; what you were seeing at that moment on the screen etc). Once you figure out exact steps .. it will be easier to find what option to change.

In any case: Emmet can easily be disabled (just use search box in Settings/Preferences screen) and Live Templates default expansion key can also be changed (in addition to disabling all live templates).

1
Comment actions Permalink

It was live templates, and it was space activated.  I had poked around the settings, but I'm sure I changed it accidently wihout realizing it.  At any rate. thank you for the help.

0

Please sign in to leave a comment.