[SOLVED] Phpstorm 10 reindexes infinitely

After I upgraded to Phpstorm 10 I see reindexing happen more often and take noticeably longer to finish.
For 10 minutes now I'm looking at my project which is "updating indices" (Indexing...)
then finished, and after 0.5 seconds, it indexes again. and again, again and again.

Does anyone else have that problem? I'm annoyed that it stops me from git tasks and other things...

Ubuntu 15.10, 64 bit.
PhpStorm-143.1184.87

3 comments
Comment actions Permalink

Hi there,

Anything interesting in idea.log (Help | Show Log in...) ?

Have you tried "File | Invalidate Caches..." and restart IDE? Any difference?

Please disable all 3rd party plugins (not bundled by default) -- any better?

0
Comment actions Permalink

will check and report back once I see this running again, thanks for the hints

0
Comment actions Permalink

*facepalm*


didn't exclude cache folders from the project. Excluding them from indexing did the trick

for the reference, If I happen to forget this:
right click desired folder ->  Mark directory as -> Excluded

0

Please sign in to leave a comment.