Is there a way to hide the floating browser icons?

Answered

Hi,

As stated in the title, is there a way to hide the *really annoying* floating browser icons in the top right corner of the editor? I got rid of it in PHPStorm 5/6/7 and I can't get rid of it in PHPStorm8 X-(

Thanks!

12
15 comments

Hi there,

AFAIK it can only be done by disabling all browsers in "Settings | Web Browsers". It will still leave some small "dot" .. but it's very small.

Related: http://youtrack.jetbrains.com/issue/WEB-461

3

Yes, there's this workaround but it's not what I would call a solution.

0

Came here looking for a solution too.  Thanks to @Andriy's post, I noticed that in PhpStorm 10 there's a checkbox under Settings > Tools > Web Browsers: "Show browser popup in the editor".  Wanted to update this thread in case anyone else came looking.

42

To go with Stephen's comment, in Intellij for  OSX / MacOS, you can find this setting in Preferences -> Tools -> Web Browsers

0

Stephen's solution worked for me in PHPStorm 10, but the bar was floating over code I had to modify, in a file I couldn't scroll enough to move away from the bar.

Any floating content obscuring code or other necessary information I need to see or use, especially if it can't be moved or hidden, should not be part of the experience. This bar could have easily been parked out of the way somewhere else while still visible without arbitrarily blending with other content.

2

I've done this three time in the past 2 months, they seem to keep coming back.  Just so I don't think I'm going insane, I've uncheck all an hit apply (then ok).   Now they're gone, but see you again in a few weeks fellas!  Screen shot for posterity:

2

@Raymond

There is an option at the bottom -- "Show browser popup in the editor" (provided as result of fixing the aforementioned WEB-461 ticket). That will disable such popup while still allowing to use "Open in Browser" when needed manually.

13

@Andriy

Done! Hopefully will never need to come back to this post!

0

Thank God !!!!!!! I F*CKING hate that pop up thing in the corner. 

2

Oh, thank goodness I found this post. What a horribly annoying thing...

2

It wouldn't be so bad if it were near the top of the editor, but it's like 32px down from the top, and almost always sits on top of important code. They should make it pop up when you hover over the filename in the tab, not over code!

5

Woohoo!!! Why didn't I do a Google search for this years ago??? FINALLY I have disabled that pesky little thing - what a relief!!! :-)

2

Thanks Andriy Bazanov! Just what I came here for.

(and hello from 2014/2017! lol)

1

Most irritating thing ever. Trying to write some code in top right corner of the screen and it's blocked by these stupid icons I've never used in my life.

1

This just started happening to me too in RubyMine, on .rb (ruby) files sometimes.  Unchecking the box in Preferences -> Tools -> Web Browsers -> Show browser popup in the editor [ ] For HTML files did remove it, but that popup was definitely appearing over my non-html ruby file.

4

Please sign in to leave a comment.