Unable to find Settings

I'm sure this is basic and I'm overlooking something obvious, pls be patient as I try to learn this as I want to see how it works in debugging a PHP form.

In the jetbrains tv I see that I can use this new phpstorm to use xdebug and help me evaluate using this product beyond the evaluation.

I'm using this post from 2013 as a general guide: https://jtreminio.com/2012/07/xdebug-and-you-why-you-should-be-using-a-real-debugger/

My environment is using phpbrew on yosemite osx, phpbrew on ubunutu 14 as a VM. Both running php 5.6.8.

I have gotten what is presented as the latest version of xdebug from their site and followed the instructions to config and install in both my dev environment and on apache 2.4 on the VM.

My php.ini on dev is thus and I think phpstorm recognizes it, though I don't get a confirmation on the UI like the jetbrains video (debugging configuration validation) says. The info icon does seem to report it finds that xdebug is installed:

zend_extension = /Users/sam/.phpbrew/php/php-5.6.8/lib/php/extensions/no-debug-zts-20131226/xdebug.so

This is what's in my php.ini on the VM

zend_extension = /home/sam/.phpbrew/php/php-5.6.8/lib/php/extensions/no-debug-zts-20131226/xdebug.so


Starting with the post from two years ago and with the jetbrains videos, they all refer to settings that I for the life of me cannot find in my interface. All I can find is "Default Settngs." What I think should happen is the Default is a fallback for the most used settings and for each project there are specific settings that override any default for that key. The video seems to suggest I should see a tiny gear and wrench icon in my interace on the uppper right but I've scoured the interface and find nothing like it.

I did see a popup for edit configuraions and I think I added one for my server on VM. I downloaded the bookmarklets for Safari. In the interface I set breakpoints for a couple of places in an include file for a php form. I turned on the telephone icon so that it's green. I then went back to Safari, clicked the Start debugger link (no indication anything happened as the post above says would happen) and the form does not pause as I expect but continues on and runs out.

Clicking the green arrow or the green bug attempts to open up Safari but that doesn't happen because the $_POST variable is not populated.

It took me a while to get this existing php project to be recognized by phpstorm. I *think* I set it with a server to be named later but without finding a project level settings I'm unsure if I did this right. I attempted to do a search for settings but I only found the php files named setttings.

Pls help me see where I can get this right to work as others are able to get it to work, thx, sam

1 comment
Comment actions Permalink

Hi there,

You are on Mac, right? (based on ".phpbrew" in your config)

Windows/Linux -- "File | Settings"
Mac -- "PhpStorm | Preferences"

Hint: Settings/Preferences screen has quick search box -- use to to find specific option (instead of browsing whole settings tree manually which could take a while if you are not familiar with it)

Useful links:


Please sign in to leave a comment.