Live edit not working properly in PhpStorm 8.0.3

Hi,

I have installed the IDE extension for Chrome. I also installed the Live Edit plugin into PhpStorm (8.0.3). (And restart IDE of course...)

When I run a debug session, live edit works for a bit and then stops. For example some angular code:

<div class="container" ng-init="title='My Title'">
    {{ 'Hello' }}
</div >


At first, as I change the text in the str literal 'Hellooo' the browser updates immediately, showing:
Hellooo

If I change code to:
{{ title }}

then it displays
My Title (correctly).

Then if I type:
{{ 'Hello' }}

Result is:
{{ 'Hello' }}

i.e. it stops evaluating the JS code. A reload in the browser will fix the output.

Also, Under View menu I do not see the "Live Edit", and "Reload in Browser" menu items that I have seem in some YouTube demos of the tool. So I cannot easily reload the page from the phpstorm IDE.

Any suggestions?

Thanks
Rael

3 comments
Comment actions Permalink

Hi there,

The latest version of PhpStorm is 10.0.1.

Since your 8.0.3 live edit has been reworked quite a bit (no more "View | Live Edit"). The way how it works now -- http://blog.jetbrains.com/webstorm/2014/08/live-edit-updates-in-webstorm-9/

I suggest to install latest v10 and see how it goes there (you can run multiple major IDE versions separately -- on first launch it will offer you to import your settings from previous version).

0
Comment actions Permalink

Live Edit doesn't correctly work for AngularJS - see https://youtrack.jetbrains.com/issue/WEB-6471 and linked tickets


0
Comment actions Permalink

I did manage to locate the "Reload in Browser" action (search in Settings->Key Mappings) so I could assign a hotkey. That is the main thing.

Thanks for the pointers. Good to know this is a known issue.

0

Please sign in to leave a comment.