Problem creating command line tool (laravel, artisan)

Hello

Since a few days I have the problem that PhpStorm cannot create a command line tool for artisan anymore. In the past this was no problem at all. I install laravel through composer (default version).

PhpStorm says the following:

Problem
Failed to parse output as xml: Error on line 4: Content is not allowed in prolog..

Command
C:\PHP-5.6.8\php.exe C:\Sites\development\mdt_v4\artisan list --xml

Output
[ErrorException]
The --xml option was deprecated in version 2.7 and will be removed in version 3.0. Use the --format option instead.


Any idea what could be going wrong here?

The only possible cause I can think of is a recent update of composer itself. Could that be possible? Is that where the deprecated xml option refers to? Composer reports the following version (which is no way near 2.7 or 3):

Composer version 1.0-dev (4f80e7ff68466cab970c22b425725b8058c32970) 2015-06-09 00:03:48

Any help or pointers to a solution will be greatly appreciated.

Thanks
Peter

3 comments
Comment actions Permalink

Hi there,

https://youtrack.jetbrains.com/issue/WI-27621

Seems the same -- you (artisan) are using newer version of Symfony Console where "--xml" option is no longer supported.

0
Comment actions Permalink

Indeed.
When I install the previous version of laravel (5.0.22) I can again create the command line tool.
When I install the default version of laravel again (5.1.*) by way of test, I get the same error again.

0
Comment actions Permalink

4 days trying to solve this problem with laravel`s artisan and found this:
https://youtrack.jetbrains.com/issue/WI-27653

Comment the line #72 in file ROOT_PATH/vendor/symfony/console/Command/ListCommand.php

// @trigger_error('The --xml option was deprecated in version 2.7 and will be removed in version 3.0. Use the --format option instead.', E_USER_DEPRECATED);

0

Please sign in to leave a comment.