Disable "paste into string escaping"

A while back, PHPStorm changed the way that it pasted into strings so that it escapes quotes automatically when pasted into strings (and maybe other formatting):

"Week of <?= date(\"F j, Y\", Common::StartOfWeek()) ?><br/>"


How can I turn that off? I hate it.

8 comments
Comment actions Permalink

Hi there,

The only way is to use "Paste Simple" instead of just "Paste" (there is no separate option for turning this off unfortunately).

P.S.
Since shortcut for "Paste Simple" is quite long/big (4 keys) I may only suggest to either assign custom shorter shortcut or swap them around (between normal and simple).

2
Comment actions Permalink

Yes, I'm aware of the shortcut keys for simple paste, but I don't want to have it enabled at all.

2
Comment actions Permalink

It would appear to be resolved for 10.0.2. Details at https://youtrack.jetbrains.com/issue/WI-28998.

-2
Comment actions Permalink

I'm not sure what you mean - I don't want it to "escape correctly", I want it to not escape at all.

4
Comment actions Permalink

As of 2017.2.6: CTRL+ALT+SHIFT+V

1
Comment actions Permalink

Escaping by default doesn't really work 99% of the time for me... it's always escaping the wrong things. For example, I feel like this is pretty common in Javascript:

 

"some text here"

"some other text here"

 

I want to paste `"+ someVar +"` into a couple places. Auto-escaping in this case drives me crazy. And auto-escaping really doesn't save much time even in the super lucky chance that it does work when you actually want it to.

 

However, it's not an issue. I just switched the hot keys for "paste" and "paste simple". Problem solved. I feel like it should be the default, however.

3
Comment actions Permalink

Just change keyborad shortcuts "Paste without formatting" to CTRL+V, SHIFT+INSERT

and "Paste" to CTRL+ALT+SHIFT+V

1

Please sign in to leave a comment.