Phpstorm 10 fonts

I just upgraded to Phptorm 10 from version 9. The first thing I noticed is that it broke my theme colors and the font does not look as bold and bright as version 9. Yes, I imported the old config during install.
I fixed the color issue as only some of the colors were not right, but some where. I not sure why the color brighness and boldness is different.
Is there a new setting that I am not aware of?


Same problem here. Colors are seemingly the same, but my font has blown up. I use Input Mono and in PhpStorm 10 it is way too bold. It was just fine in PhpStorm 9. See attached images. There is no clear option to change the weight of the font, or change the aliasing.

EDIT: found a solution of sorts, requires cloning the font with a custom setup:

Essentially you should clone the font and remove all traces of hinting in it. Not excatly the same, but my font reverted back to a easier weight, which is not as strainful for my eyes.


Hi there,

What is your OS? I guess Linux or Mac.

Please try changing Antialiasing options in "Settings/Preferences | Appearance & Behaviour | Appearance | Antialiasing"


Same problem here... switched from phpStorm 8 to phpStorm 10, imported my settings and the font is now blurry (Font is not overrided).

If I change the antialiasing in the Appearance config, the font becomes skinny.

I'm using phpStorm on my Macbook Pro Retina on an external monitor (DELL U2412M). When switching on my laptop monitor (retina), no problem.

I downgraded to phpStorm 8 and my font is clean on both monitors.

Any clue?


I am using Mac El Captain 10.11.
I tried the antialiasing but it only makes it look jagged.


Note that while importing my settings, some colors didn't follow, even though these colors were set in my settings, but this is not a minor issue. The real issue here is with the font antialiasing.


I rollbacked to phpStorm 8.0.3 and no more font antialiasing problem, my eyes are happy! :p


Same issue for me. Upgraded from PhpStorm-141.2462 to PhpStorm-143.381.48 and imported settings.

All fonts in the IDE appeared with greenish shadow-like blurring.

The editor looked ok (I use custom font there).

By changing Antialiasing to 'Grey scale' things improved, but only to a point, also turning it off does not help.

I reverted back to 141.2462.

Running openSUSE 13.2 with java-1_8_0-openjdk.


Any update on this issue...can developers from Jetbrains please respond? Thanks


It might be best to log a support ticket for this to be sure the PhpStorm staff looks into the problem.


I got the ugly font problem as well. I'm running openSUSE 13.2 and I can narrow it down to the JRE I use.

When I installed openSUSE in the first place, the font rendering (of the whole system) was not very good. So after some googleing I installed some packages with the infinality patches, including a patched openJDK. Especially in PHPstorm that was a massive improvement.

Not it seems that v10 brings its own JRE, resisting in the 'jre' folder. When I rename that folder, the startup-script falls back to my patched openJDK giving me back my nice rendering from v9 (see attached picture in a new tab, font is DejaVu Sans Mono).
However the performace is noticably better with the supplied JRE ...but the ugly fonts are a real deal breaker, when you have to look at code all day.

Edit: here is another tip: create a file named phpstorm64.vmoptions (or phpstorm.vmoptions for 32bit) in your ~/.WebIde100/ folder and insert the following content:

Play with the useSystemAAFontSettings=lcd setting a litte to get the best result for your monitor. Imho this is not as good as the infinality patches, but better than the default settings.


Please sign in to leave a comment.