Apache stops working due to Comment Block Shortcut Style

Hello everyone.

I guess I may have find a bug.  

When I use the Comment Block Shortcut (Ctrl + Shift + /), I get an error when trying to load that page and my Apache server stops working (Windows OS even gives me an error dialog).

When you use that shortcut, phpstorm comments your code like this:  

{{--
   //Commented code here
--}}

I'd like to know if it's possible to change this characters used to comment code, to customize it. Is it possible?  

I'd like to change the {{ -- --}} for <!-- -->


<!--

   //New Comment Block Style
-->

Is this something possible to do ?   Already checked in Settings>Keymap>Comment Block but there is no option to edit anything.

1 comment
Comment actions Permalink

What files do you work with? .html, or .hbs, for examle? In the first case, check 'Open HTML files as Handlebars/Mustache' option in Settings/Languages and Frameworks/JavaScript/Temlplates - is it enabled?
Note that you can choose language used for creating comments in temlates in Settings/Languages and Frameworks/JavaScript/Temlplates, Language for comments - choose 'HTML' there if you like to use <!-- -->

0

Please sign in to leave a comment.