Comments Appearing in Different Language/Encoding in PHPStorm

I opened up PHP Storm this afternoon to get some work done and noticed that my comments were appearing in a different language or encoding:
phpstorm_comments.jpg
When I copy/paste them into any place else, they will appear as normal text. I checked my plugins and nothing seems like it would affect that.

Any help would be appreciated because I cannot really use this thing until I get it fixed. Is there some setting somewhere that I am missing? I disabled all non-JetBrains plugins and I searched for encoding and language settings but nothing jumps out at me.

2 comments
Comment actions Permalink

Hi there,

Your IDE version exactly? And OS?

How many files are affected? I mean -- just certain files or all?

"Settings/Preferences | Editor | File Encodings" -- find your file there and force specific encoding (also accessible via Status Bar .. of "File" menu) . Also check there that correct Project/IDE encoding is set (I do not know what you are using there, but I would recommend using UTF-8).

When I copy/paste them into any place else, they will appear as normal text.

You mean -- copying comments from opened file in the editor?

Sounds stupid and rather unlikley .. but it may also be a font issue (e.g. if it affects all such text .. or if it affects text renderd in certain style -- e.g. italic).

0
Comment actions Permalink

While typing my response to you, I accidentally discovered the problem. It's the font. For whatever reason my copy of Adobe Source Code Pro from TypeKit is not compatible with JetBrains software. The second I flipped it to something else like Lucida Console every thing appeared as normal.

0

Please sign in to leave a comment.