Web Path Question

Hi jetbrains community. I want to apologize in advance as I feel like this question has to have an extremely simple answer. I'm new to the jetbrains IDE environment and in turn cannot figure out how to resolve my problem. I imported a web application project I was working on and accidently specified the wrong path in the 'Specifiy Web Path (Local)' step. Now I have literally no idea as to how to change that setting within the IDE. I see where I can change my web root for all of my projects but nothing that specifies the local web path for my project. Thanks for any help in adance and sorry for my stupidity!

3 comments
Comment actions Permalink

Hi there,

I'm not sure what you mean exactly (some screenshots with some hints would be very handy to have) but I would check this:

1. "Settings/Preferences | Build, Execution, Deployment | Deployment" -- check the stuff there (Mappings tab in particular) -- this is the most likely place based on your description.

2. "Run | Edit Configurations..." (or the same via drop down box on main toolbar -- next to Run/Debug buttons) -- check paths in your configurations there (ignore the Defaults branch for now)

I see where I can change my web root for all of my projects

And where it is located? I'm asking because I'm still confused about all of this / the way it's worded.


P.S.
If anything -- you can always delete .idea subfolder (this project settings) while project is closed and start from scratch.

0
Comment actions Permalink

Thanks for the response Andriy. Sorry for the pretty terrible question. I posted that in haste and frustration at the

end of the day yesteraday. Think I'm just going to delete the .idea and and start from scratch. To be a little more clear on my question I was following this guide and when I got to the step where you 'specify web path' I accidently specified a web path that was a directory too deep. So when I went to 'run' my web application it wouldn't open the correct address in the browser. Honestly that's probably still not %100 clear so if you'd like me to clear it up more just let me know. Thanks for the help though!

0
Comment actions Permalink

That's most likely a deployment settings (yep, it is used even if you have no need to move/copy anything -- in this case entry of "In place" type will be used) as this is where base URL is taken from.

0

Please sign in to leave a comment.