Override auto formatting?

There are times the auto formatting doesn't work perfectly.

Heres and example:

 
<?php
  if (isset($atts['association_link']) && isset($atts['association_image'])
&& $atts['association_link'] !== '' && $atts['association_image'] !== ''):
?>
<p class="in-association"><strong>In association with</strong> <a href="<?php echo $atts['association_link']?>"><img src="<?php echo $atts['association_image'] ?>" alt="" class="events-assoc-image"></a>
  <?php endif ?>


So I want to move <?php endif ?> to start below <p class..>.
But hitting the delete key once moves <?php endif ?> to the same line as <p class..> instead.

Is there anyway to manually override the auto formatting?
Its a .php file.

1 comment
Comment actions Permalink

Hi there,

"Settings/Preferences | Editor | General | Smart Keys --> Unindent" -- try choosing other option there

0

Please sign in to leave a comment.