4 comments
Comment actions Permalink

Hi there,

It's Language Injection fragment (another language (SQL in your case); such background allows you to see that it was detected as such and allows additional functionality)

  • If you want to just remove background, you will have to edit your color scheme at "Settings/Preferences | Editor | Colors & Fonts | General | Injected language fragment" (actual style may be called a bit differently in different IDE version -- just use settings search box (top left corner) to quickly find it)
  • If you want to remove actual injection altogether -- "Settings/Preferences | Editor | Language Injections" -- disable all unwanted rules



https://confluence.jetbrains.com/display/PhpStorm/Language+Injections+%28mix-ins%29+in+PhpStorm

1
Comment actions Permalink

Yeah, it worked!

Thank you very much! :D

0
Comment actions Permalink

What a distraction.  Too much time consumed here trying tog make you happy.

Finally disabled SQL dialect and guess what... the code is till highlighted with "SQL dialect is not configured".

Please just leave me alone and let me get some work done.  I want to see black and white, not a pizzeria of suggestions.

Off means off.

 

 

0
Comment actions Permalink

David, you can disable the SQL | SQL dialect detection inspection at File | Settings | Editor | Inspections. Let me know if that doesn't help.

0

Please sign in to leave a comment.