Webstorm 10.0.4 - node.exe config GUI missing?

The Webstorm help page has a huge list of "Configuration Tab" fields that I do not see in my config:
https://www.jetbrains.com/webstorm/help/run-debug-configuration-node-js.html?search=node.exe%20bad%20option

This is what my node.exe "Configuration Tab" looks like:
webstormscreenshot.PNG
Wow the upload made that small. I hope you can click on it to see the full size.

I attached this image as well.



Attachment(s):
webstormscreenshot.PNG
4 comments
Comment actions Permalink

Hi there

The screenshot is for General node.js configuration (path to node executable; you are actually inside Settings/Preferences screen) while your link is about actual Run/Debug configuration which are accessible via "Run | Edit Configurations..." or drop-down box on main toolbar (next to Run/Debug buttons) -- https://www.jetbrains.com/webstorm/help/creating-and-editing-run-debug-configurations.html?search=node.exe%20bad%20option

Related links:

0
Comment actions Permalink

Wow. Can you please put that in your help file. How/where to get to that node.exe config tab that you just gave me.
Run | Edit Configurations | Defaults | Node.js

Package Upgrade not working:
In my screenshot of what I thought was the Node.exe config tab, you will see all my Packages that need updating/upgrading.
They do not update/upgrade. I have let it run overnight and nothing ever happens...
I have restarted Webstorm several times. I discovered this issue about two weeks ago and cannot reslove it.

Terminal:
Yet another problem is with Terminal. I changed the Shell Path to a Windows 10 cmd.exe version. The terminal would load in Webstorm but I could not type into it.
Because I could not get that to work I put the Shell Path back to the way I found it which is just "cmd.exe" with no path. Webstorm I think is still using my old shell path and I still cannot type into it..
Terminal.PNG
Terminal2.PNG

Thanks,

0
Comment actions Permalink

Wow. Can you please put that in your help file. How/where to get to that node.exe config tab that you just gave me.
Run | Edit Configurations | Defaults | Node.js

1) Cannot do that myself -- I'm not working for JB
2) The link was taken from "See Also" section at the end of the article
3) FYI -- you are editing entry under "Defaults" branch and not actual specific Run/Debug config.  Such defaults will be used to pre-fill fields when you create new Run/Debug Configuration of that type -- they will not affect already exiting configurations.

Package Upgrade not working:

No idea (not a JS person and do not use this particular functionality myself). I manage (install/update/remove) my npm packages trough command line -- works more reliable for me.

If that's a known issue then it may already be fixed -- please try v11 EAP build. Otherwise feel free to submit a ticket with the idea.log attached (Help | Show Log in...) to https://intellij-support.jetbrains.com/hc/en-us/requests/new

Terminal:

Known issue. Already resolved for v11 (142.xxx branch).

In meantime (v10) you may use this: http://stackoverflow.com/a/30170046/783119
0
Comment actions Permalink

I gave you an upvote on SO. Thank you!

0

Please sign in to leave a comment.