GWT: EventObject is not present in the JRE emulation library.

I may be missing something basic, but I'm not sure.

I'm using GWT 1.3.3, and everything else I'm doing is working correctly, but when I try to build a class that extends the java.util.EventObject class, I get an error that says that the java.util.EventObject class is not present in the JRE emulation library. I've checked my gwt-user-1.3.3.jar and the class exists.

If I compile my project with the GWT compiler outside of Intellij it seems to work correctly.

1 comment
Avatar
Nikolay Chashnikov

Hello Caleb,

It's a known bug (http://www.jetbrains.net/jira/browse/IDEADEV-10950).

I may be missing something basic, but I'm not sure.

I'm using GWT 1.3.3, and everything else I'm doing is working
correctly, but when I try to build a class that extends the
java.util.EventObject class, I get an error that says that the
java.util.EventObject class is not present in the JRE emulation
library. I've checked my gwt-user-1.3.3.jar and the class exists.

If I compile my project with the GWT compiler outside of Intellij it
seems to work correctly.



0

Please sign in to leave a comment.