Problems with PhpStorm 9.0.2 and Subversion over SSH

Answered

Hello together,

I'm struggling with a problem with PhpStorm 9.0.2 and Subversion.

I have different repositories, some of them with SSH, some of them without. The repositories without SSH work fine, but I cannot access the repository within PhpStorm.

svn+ssh://my.username@svnserver/var/svn/project/trunk

I've uploaded my private key file to the server and can access the server using TortoiseSVN or via Putty.

I've tried to change Settings > Version Control > add current project > Configure VCS as Subversion > SSH settings with password, private key file and Subversion config. Nothing of them worked for me. Do I need an additional openSSH client for the SSH executable right here or can I use putty for this? How does a correct configuration look like? Can anybody post some screenshots in order to help me?

Furthermore I've already tried different versions of TortoiseSVN from 1.7 to 1.9 without any changes. It always prompts for the password, after entering the password, the same password popup is shown again prompting for the password.


svn: E170013: When using svn+ssh:// URLs, keep in mind that the --username and --password options are ignored because authentication is performed by SSH, not Subversion svn: E170013: Unable to connect to a repository at URL 'svn+ssh://my.username@svnserver/var/svn/project/trunk/src' svn: E170012: Can't create tunnel svn: E720002: Can't create tunnel: Das System kann die angegebene Datei nicht finden.

Where can I find proper information how to solve this issue?

Best regards and thanks for any help,
mrfresh

3 comments
Comment actions Permalink

please see https://youtrack.jetbrains.com/issue/IDEA-118615#comment=27-656654 - does setting up the tunnel in  svn config file and using this config in PHPStorm configuration help?

0
Comment actions Permalink

I'm having the exact same issue.
I don't want to auth with passkey but with password.

svn+ssh://my.username@svnserver:myport/var/svn/project/trunk/src

does not work. it works well in eclipse

0
Avatar
Vladimir Luchansky
Comment actions Permalink
0

Please sign in to leave a comment.