FileEncodings Windows 10 not works

Hi,

i use the latest PHPStorm 9.0.2 on Windows 10. If i set the file encoding on the bottom right for a single file, will this works. But if i marked some php files on the Directory-List, click on "File" > "File Encoding" or if i go over Settings > Editor > File Encoding and set it to UTF-8, nothing will change.

Have anyone else this bug too?

1 comment
Comment actions Permalink

Hi there,

It's quite odd .. as that File Encodings settings screen is actually a place where it always works for me...

I'm not using Windows 10 so cannot check and confirm this part .. but could you please show that settings screen -- what do you have for IDE/Project encoding boxes? If you do have "System Default" -- try setting actual encoding (e.g. UTF-8 or whatever is more suitable for you) and restart IDE -- will it behave better now?

0

Please sign in to leave a comment.