Live Edit stops when include css files with<!--[if lte IE 8]>

Dear forum,

Just boght phpStorm and really trying to get Live Edit to work.

But Chrome and or phpStorm stops after reading 4 lines down in the html document (a index.php file).

Any ideeas, hints or thoughts on this would greatly appreciated,
Using Windows 10. The index.php file is not empty, created in Dreamveawer.

Thanks in advance.

phps.jpg

1 comment
Comment actions Permalink

I might have found the reason for this strange problem.

In the file /index.php that stops after 4 lines of html code, I have the line <?php include('includes/head.php'); ?> in the top of the document.

In head.php, I have the following lines:

<meta charset="utf-8" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<link rel="stylesheet" href="/assets/css/main.css" />
<!--[if lte IE 8]><script src="/assets/js/ie/html5shiv.js"></script><![endif]-->
<!--[if lte IE 8]><link rel="stylesheet" href="/assets/css/ie8.css" /><![endif]-->
<!--[if lte IE 9]><link rel="stylesheet" href="/assets/css/ie9.css" /><![endif]-->
<link rel="stylesheet" href="/includes/sticky.css" />
<script src="/assets/js/jquery.min.js"></script>
<script src="/includes/sticky.js"></script>


If I remove the following 3 lines in head.php, everythings seems to be working as expected?

<!--[if lte IE 8]><script src="/assets/js/ie/html5shiv.js"></script><![endif]-->
<!--[if lte IE 8]><link rel="stylesheet" href="/assets/css/ie8.css" /><![endif]-->
<!--[if lte IE 9]><link rel="stylesheet" href="/assets/css/ie9.css" /><![endif]-->


Anyone have any clues, please?
Thanks in advance!

0

Please sign in to leave a comment.