Typescript 1.5

Hi,

With WebStorm 9 I could use TypeScript 1.5 with a FileWatcher. WebStorm 10 has the Typescript compiler integrated.

How can I Work with TypeScript 1.5 in WebStorm Beta, only using a file Watcher ?

Thanks in advance

4 comments
Comment actions Permalink

You can use in the same way as in WebStorm9 - don't enable TypeScript compiler, use file watchers instead. Or, if you prefer using TypeScript compiler, set it up accordingly: specify a path to the node_modules/typescript/bin folder of your global typescript 1.5 installation (like C:\Users\user.name\AppData\Roaming\npm\node_modules\typescript\bin\ ) in 'Compiler version' field

0
Comment actions Permalink

I will disable de compiler and createmy watcher.

Thank you very much

0
Comment actions Permalink

It worked.

I have installed TypeScript: npm install typescript. The lastes version 1.5 was imported

Then in Settings -> Language and Frameworks -> TypeScript i have clicked the edit button in Compiler version then in Custom Directory I have set <project directory>\node_modules\typescript\bin

And the project is using TypeScript 1.5

Thanks again

0
Comment actions Permalink

in which phpstorm version typescript 1.5 is supported ?

0

Please sign in to leave a comment.