PhpStorm 9 multi monitor

Hello

What should I do to use PhpStorm 9 on multi monitors? On PhpStorm 9 for each tab there is a tab name (with x to close this tab) and when moving this tab to second monitor I will have moved this tab to second monitor. But on PhpStorm 9 the tab looks different, there is no closing x, and the name of the tab is not looking the same and it's impossible to simple drag it to second monitor.

5 comments
Comment actions Permalink

What platform are you using? This doesn't help you, I realize, but on OS X (Yosemite), I still see the x and can move tabs between monitors with no problem.

0
Comment actions Permalink

Hello
I'm using Windows 8.1 At the moment there are no names on tabs at all (they used to be here today morning). At the moment tabs look like on below screen.tabs.jpg
In PhpStorm 8.0.2 everything works fine.



Attachment(s):
tabs.jpg
0
Comment actions Permalink

Strange. I'll have to bow out and defer to anyone else, as I can't reproduce this, but if it makes you feel better, I'm sure it's not an "on purpose" design change.

0
Comment actions Permalink

Hi there,

Main Menu | Window | Editor Tabs | Tabs Placement -- make sure it does not say "None" (or the same via "Settings | Editor | General | Editor Tabs | Placement")

"Settings | Editor | General | Editor Tabs | Show "close" button on editor tabs" for close "X" buttons on tabs.

If above does not help: please disable all 3rd party plugins (not bundled by default) and see if it will work there. If it does -- try re-enabling one plugin at a time and restart in between.

0
Comment actions Permalink

The problem I'm having right now with PhpStorm 9 on multi monitor is that the maximize button doesn't work on an editor I've "torn off" and dragged to my secondary monitor (it's a widescreen monitor oriented in portrait mode. Imagine a monitor much taller than it is wide.).

More detail:

The editor window on the secondary monitor is in Normal mode. I click the Maximize button (also tried double clicking title bar) and it looks like what might be happening is that the window is using the primary monitor dimensions when maximizing. The resulting "maximized" window is at the top of the secondary monitor, slightly offset from the top left corner, extending past the right edge of the secondary monitor (such that the chrome on the right title bar cannot be seen). The window extends downwards maybe halfway down the secondary monitor.

I tried the same behavior on a bunch of other apps and they all behave as I would expect.

Windows 10, PhpStorm 9.0 Build 141.1912.

0

Please sign in to leave a comment.