Typing / shortcut issue? Tip needed

Hi,

I have been oddly getting menu highlight activated, same as when you press Alt on Windows. This keeps happening in PhpStorm 9. It is when I have typed either $ or use completion for function (for the brackets and when I hit enter - boom!). I will be typing and suddnely I am in menu, instead of typing. And if I was trying to write a variable, only the dollar sign would be left, staring me. The thing is, this didn't happen before on PhpStorm 8 (or if did, very rarely). So I don't think this is because I am typing poorly and hitting some other random keys while I type. The upgrade did override my keyboard shortcuts though. Unfortunately, if this is a PhpStorm shortcut, I don't really know quite what term to look for to disable this (I have tried!) and I type too fast to notice if it actually might be some specific I am doing... Has anyone a clue what I might be hitting that is causing this or even point me in the right direction? Since as said, I didn't have this issue with PhpStorm 8 and it really distracting having to hit Esc often and remember again what I wanted to type.

Thanks!

Regards,
draeconis

2 comments
Comment actions Permalink

Are you on Windows? What IDE theme (Settings/Appearance&Behavior/Appearance/Theme) is used?

0
Comment actions Permalink

Yes, Windows and the Intelli one...

0

Please sign in to leave a comment.