jsp Debugging will not WORK!!! please help

Hello, I can not get my jsp's to debug/breakpoint.
Here are the specifics
1)Build #701
2)C:\ApacheTomcat4 (4.0.6)
3)compiler output:
C:\memberclicks\leprechaun\CURRENTVERSION\webapp\WEB-INF\classes

4) in the webapp Run/Debug boxes:
- Catalina home: C:\ApacheTomcat4
- Config files: C:\memberclicks\Tomcat\conf (used to work like this)

Application Context = /mc

From the server.xml in C:\memberclicks\Tomcat\conf
]]>

I hope this is enough information. The app runs and i can step into the servlets and even the classes that are called in the jsps, but i can not step thru the JSPS.

Thanks for any help




6 comments

Where are you placing your breakpoint in the JSP? That actually matters!

0

I have tried it in all JSP code area. The red ball appears as a ball not an X.
It used to work, the last time i needed it

0

Is the breakpoint validated i.e. is there a checkmark on the breakpoint?

--

Best regards,
Eugene Zhuravlev
JetBrains, Inc, http://www.intellij.com
"Develop with pleasure!"



0

No there is no CHeckmark on the breakpoint

0

This means the corresponding java class by some reason was not loaded (or
class with the same name was loaded from another place)
Could you please set up a test project that illustrates the problem and send
it to me for investigation?

--

Best regards,
Eugene Zhuravlev
JetBrains Inc. / IntelliJ Software, http://www.intellij.com
"Develop with pleasure!"

"Randy Paries" <randy.paries@unitnet.com> wrote in message
news:14517597.1051810550773.JavaMail.jrun@is.intellij.net...

No there is no CHeckmark on the breakpoint



0

Well I created a very simple servlet and jsp project and those worked fine. So for some reason my project is screwed up. I tried to create a new project and still no joy.
Do i need to look at SourcePath, Classpath or projectpath to make sure the jsps are included. (although they are in each)

I am confused.....

0

Please sign in to leave a comment.