Problems with tomcat integration

Hello People,
I have just purchased idea 6 and wanted to try out the jsp development.
I have installed tomcat 5.5 locally and configured idea to use it.

Here what I do new project..
New Web Module...
A new JSP
configure to run the module...
and run

Tomcat gets started and and my browser pops up. But i get a 404. I have tried several different paths but all 404.

The tomcat examples work fine.

Any ideas will be appriciated

Thank you
// Peyman

Message was edited by:
Peyman Zehtab-Fard


First I suggest a few basic checks. Check that you have selected to deploy the application, probably best to start with to ensure its deployed as exploded.

To do this, look at the run configuration, select tomcat, then choose the deployment tab. Select your web application and ensure that it is being deployed.

Also ensure the checkbox to deploy the application is checked.

These are worth a check before going any further in diagnostics.

PS: this page will also tell you the path that its deployed to on tomcat (application context).


Thank you for the reply.
I thought I must put the jsp file in the projects root at the same level as WEB-INF.
So the problem was solved by putting the JSP file in the resources folder.

Thank you again


Please sign in to leave a comment.