Can't change vm version for running idea 3.0.x

I'm currently running IDEA 3.0.3. I've been working on a rather large project for a while (3500+ classes). 3.0.3 crashed intermittently when doing memory consuming operations like large code scans. I suspect the memory leak problem in JRE/JDK 1.4.1_02 so I tried to run Idea under 1.4.2beta. But I found out that IDEA no longer allows me to change the VM version to use for running IDEA. I used to change this often when using Idea 2.x. Why is this? Is there any way to go around this limitation?

5 comments

Hello,

What kind of crash do you mean? Is it OutOfMemory exception or JVM crash?
Couldn't you please send error messages.

--
Best regards,
Anton Katilin
-


JetBrains, Inc / IntelliJ Software
http://www.intellij.com
"Develop with pleasure!"

"Claes Gille" <jiveadmin@jetbrains.com> wrote in message
news:25946736.1051272408578.JavaMail.jrun@is.intellij.net...

I'm currently running IDEA 3.0.3. I've been working on a rather large

project for a while (3500+ classes). 3.0.3 crashed intermittently when doing
memory consuming operations like large code scans. I suspect the memory leak
problem in JRE/JDK 1.4.1_02 so I tried to run Idea under 1.4.2beta. But I
found out that IDEA no longer allows me to change the VM version to use for
running IDEA. I used to change this often when using Idea 2.x. Why is this?
Is there any way to go around this limitation?


0

It's a VM crash almost certain memory related. But my real question was why i'm not allowed to run Idea under 1.4.2.

0

Because it's not out yet, and as all beta software it has some bugs that prevent us to run IDEA with it.

/kesh

0

No, you misunderstand. I mean why can't I change the vm version at all. Idea now checks that the vm version is exactly 1.4.1_02. It does'nt allow me to change the vm version at all. I did this all the time with 2.x. I'm just curious of why this has changed.

0

Why you can't simply replace the engine electronics in your car?
Because it might not work any more.

BTW, please search the mailing list, there was already a discussion,
why 1.4.2-beta cannot be used.

Tom

0

Please sign in to leave a comment.