PHPStorm 9 and PHP-Debugging not work?

I use now PHPStorm 9, the configuration is absolutely the same as before...

I have a Server with Port and Xdebug and the correkt path, with PHPStorm 8 it's work.

I click on "Start Listening for PHPDebug Connections" and then i start debug in the Browser and then no stopping in phpstorm at this point... what i have forgot?

(And i don't can use "Run"-Option, this is not possible for my cases)


Anybody have tested this on phpstorm 9?

6 comments
Comment actions Permalink

Hi there,

Well -- it definitely work here on my computer (WIndows 7, PHP 5.5 & 5.6; local debug).

  • What's your config?
  • Is it local or remote/VM debug?
  • What does xdebug log says about your debug attempts: http://xdebug.org/docs/all_settings#remote_log
  • If local -- can you debug local CLI scripts?
  • If you start brand new simple project -- will debug work there?


Can you check that "Settings (Preferences on Mac) | Languages & Frameworks | PHP | Servers" is configured correctly (as it was in v8)?

0
Comment actions Permalink

Also: v9 has some tools that should help with identifying possible problems -- do they work for you any good?

http://blog.jetbrains.com/phpstorm/2015/07/debugging-improvements-in-phpstorm-9/

0
Comment actions Permalink

2015-07-10_15h17_03.png

- It's a VM and i called with trunk.boilerplate.local
- xdebug.log not writing anytime
- I have start a new project with test/public_html/test.php -> also not work?
- Configuration is 1:1 the same as in v8.

0
Comment actions Permalink
- xdebug.log not writing anytime

If you put the path to the log correctly (is writable by xdebug/webserver process) then xdebug should write every connection attempt.

Check file permissions ... and make sure that you have restarted your web server (in case it does not pick up changes in php.ini automatically -- standard stuff).

Maybe .. it simply does not see debug parameters/cookies hence no debug attampts? If you still have v8 installed:
- does it work there? If it works .. then it's not PHP/remote side issue.
- I hope you do not run more than one IDE at the same time (in case it already uses that xdebug port)

Try xdebug.remote_autostart = 1 so that xdebug will attempt to debug every single request. You may also place xdebug_break(); in your code to trigger breakpoint programmatically.

0
Comment actions Permalink

If only thing has changed is IDE version (and it still works in v8) ... then maybe check your firewall (PhpStorm is the one who received incoming connections so must be enabled/whitelisted in firewall)

0
Comment actions Permalink

Great Thanks to you Andriy

It's really the firewall, that have blocked the connection. Now work it well.

0

Please sign in to leave a comment.