How to disable notification "This file is indented with tabs instead of 4 spaces"

How to disable notification "This file is indented with tabs instead of 4 spaces" forever?
It shows every time I open a file.

4 comments
Comment actions Permalink

Hi there,

"Settings (Preferences on Mac) | Editor | Code Style -> Detect and use existing file indents for editing" -- should help.

0
Comment actions Permalink

When this option is checked new created lines always begin from spaces (not tabs). It's strange but the fact!

0
Comment actions Permalink

Not sure what you mean here.

My idea was to disable that option if enabled.

If that option is disabled .. and you have set to use tabs .. but you still have spaces .. please check:

1) Check settings for specific language/file type -- if code style for that language exist then it will override General settings.

2) If you have Editorconfig plugin enabled (not bundled by default with PhpStorm .. but bundled with WebStorm) .. and have .editorconfig file anywhere in your project path ... then check its' settings -- by the nature of this plugin, settings from such file will override what you have got in your code style.

0
Comment actions Permalink

Thanks! I didn't look in JavaScript settings :)

0

Please sign in to leave a comment.