Copy copies background also


This drives me crazy.  Is there a way to get webstorm to copy readable code from the editor?  I'm using a dark theme so I end up with lousy colors after I paste into OneNote or other editors


WebStorm uses rich text format on copying by default. You can use Edit/Copy as Plain Text to copy text without colors, etc.


That seems to contradict the documentation, unless the documentation is only talking about pasting text into PyChamr:

In any case, I think that the default behavior isn't useful.



@Eli Stevens

Not sure about PyCharm (although it should be the same for all IDEs) but in PhpStorm you can disable such feature at

"Settings/Preferences | Editor | General --> Copy as rich text by default".


I'd looked for something along those lines, but missed it. Thanks!


Found this topic while trying to figure out how to copy stuff into OneNote just like Dave Schinkel.

It turns out, there's now an option to apply a different editor scheme altogeter when copying text. Figured it might be worth sharing.


Please sign in to leave a comment.