Control-M

If I open a file with "^M" in it, idea puts an empty line between all the lines.
Isn't there a way to disable/customize this?

2 comments
Comment actions Permalink

Would I be right in assuming that you're on a linux box editing a file that at some point has been edited on a windows box?

The ^M characters are windows CRs and IDEA will interpret them according to the line feed settings. Your best bet is to look at why you have CRs in the file in the first place - do you want to explain your environment a bit more?

cheers
dim

0
Comment actions Permalink

I'm editing the file on windows platform. But we store files in version control in unix format (which does not have ^Ms). Some files have ^Ms due to some mistake (maybe someone edits it in windows). These files have the issue.

Basically I want to know if there is a setting to ignore Ms or to treat combination of \nM as a single new line

0

Please sign in to leave a comment.