problem starting on OSX+Java6

I installed Java6 on my MacBook (OS X 10.4.8). The /System/Library/Frameworks/JavaVM.framework/Versions/Current still points to 1.5.0. However I cannot start IDEA - I get the "Java Versions Mismatch" error dialog, complaining that my JDK version is 1.6.0-dp.

How can I go around this?

2 comments
Comment actions Permalink

Partially answering myself:

setting IDEA_JDK to point to 1.5.0 and using the /Applicayions/IntelliJ...app/bin/idea.sh starts idea, but I still can't start it the "normal Mac" way.

0
Comment actions Permalink

Did you try to set the JDK version in the Info.plist file? If not, open Applications, right click on IntelliJ IDEA -> Show packet contents. Then go to Contents, double click Info.plist, search for the Node Java/JVMVersion and change its value to 1.5. That should do the trick I guess.
Just in case: Save a copy of the original .app...

Regards,
Wolfram.

0

Please sign in to leave a comment.