Ant task works outside IntelliJ but not inside... works in 5.1.2...

My build.xml kicks off a custom ant task that uses Velocity to generate some files. I was using IntelliJ 5.1.2 and my build.xml was working fine.

I just upgraded to IntelliJ 6.0.2 and now Velocity can't find my template (even though the top level directory is specified on the path for the taskdef).

So, what changed with IntelliJ Ant integration from 5.1.2 to 6.0.2?

The build file works fine outside of IntelliJ using 1.6.5.

2 comments
Comment actions Permalink

Hello Michael,

Do you mean ant running, not the editor functionality? All settings, affecting
running ant from IDEA, are in Build File Properties dialog (select the project
in Ant Build window, and open Properties from context menu). Check please,
are they Ok in 6.0.2. (E.g. are they the same to 5.1.2; or what's the difference
to ant which successfully runs the build outside IDEA.)

My build.xml kicks off a custom ant task that uses Velocity to
generate some files. I was using IntelliJ 5.1.2 and my build.xml was
working fine.

I just upgraded to IntelliJ 6.0.2 and now Velocity can't find my
template (even though the top level directory is specified on the path
for the taskdef).

So, what changed with IntelliJ Ant integration from 5.1.2 to 6.0.2?

The build file works fine outside of IntelliJ using 1.6.5.

Alexander.


0
Comment actions Permalink

I had to add the directory with the template to the additional classpath in the build properties file.

0

Please sign in to leave a comment.