Failed installation of zend-escaper with Composer

Hi!

I'm trying to install zend-escaper but I'm getting this error:

Capture.JPG


This is strange as my PHP version (from phpinfo()) is 5.5.19, the message claims it is 5.3.5(!) which should satisfy the requirement anyway.
My ZF version is 1.12.13 I'm using PHP Storm 8.0.1

Can anyone help please?

Thanks Tomasz

2 comments
Comment actions Permalink

Hi there,

Message suggests that you have more than one php installation on your PC.

1) What version do you get if you execute "php -v" in terminal (built-in and native one)?
2) What do you get when execute "where php" in terminal (built-in and native one)?
3) Do a global search for "php.exe" on your computer and do #1 for each found result.
4) What PHP Interpreter do you have configured in PhpStorm: "Settings | Languages & Frameworks | PHP"? Make sure it points to your 5.5

the message claims it is 5.3.5(!) which should satisfy the requirement anyway.

a) This detection and message is done by actual composer and not PhpStorm
b) 5.3.5 does not satisfy >=5.3.23

P.S.
Latest stable version of PhpStorm is 8.0.3 -- worth upgrading anyway.

0
Comment actions Permalink

Hi Andriy!

Thank you for your reponse. Indeed I had some kind of mess with the PHP.

Now it installed successfuly

regards
Tomasz

0

Please sign in to leave a comment.