Keyboard layout randomly changes from UK to US?

Answered

Using 6.0.2 Beta, Windows XP x64

I dont think this has anything to do with Windows - as no other applications (e.g. Firefox / Notepad) are affected when I experience this problem.

Something seems to change the keyboard layout from UK to US (so Shift-2 = @ rather than ")

Restarting IDEA fixes it until it happens again.

Any ideas?

Thanks - Ben

7 comments
Comment actions Permalink

Not really Idea's fault, but yeah somehow Idea's shortcuts often also caused me to accidentally
activate this windows feature.
I am on a german windows so I am not sure about the button and menu labels in english:
Go to Windows' Control Panel -> Region and Language Settings -> Languages Tab ->
In the dialog that opens select the "Keyboard" button. You'll probably find that the
key combinations "alt+left-shift" switches the input setting. Just disable this.

dilator wrote:

Using 6.0.2 Beta, Windows XP x64

I dont think this has anything to do with Windows - as no other applications (e.g. Firefox / Notepad) are affected when I experience this problem.

Something seems to change the keyboard layout from UK to US (so Shift-2 = @ rather than ")

Restarting IDEA fixes it until it happens again.

Any ideas?

Thanks - Ben

0
Comment actions Permalink

I'll give it a try - it certainly looked like other programs were responding unchanged. I've removed the offending US keyboard layout just in case!

0
Comment actions Permalink

I have also this problem.

When I switch to intellij the keyboard switches language

But I don't want to disable alt-shift, it is deep habbit

What to do ?

I wrote about this bug but got no helpful response

It happens on keyboard window activation and on mouse activation

1
Comment actions Permalink

It can happen if you press Alt+Shift by accident. Windows has a setting to remember keyboard layout per window/application. This way it will switch automatically when you switch to IntelliJ IDEA window if you've already changed the layout inside IntelliJ IDEA by pressing Alt+Shift, either intentionally or accidentally.

2
Comment actions Permalink

In intellij I do programming only -  which means english only.

It switches to other language upon windows activation randomly and when activated my mouse as well.

It happens in android studio as well - which is the same platform.

It does not happen in any other program

0
Comment actions Permalink

It's unlikely that you are using the same keyboard shortcuts in other programs. So far it looks like you press a shortcut that switches the keyboard layout by accident.

0
Comment actions Permalink

In my case, press "Ctrl + Shift" changes keyboard.

Turn it off in Windows.

0

Please sign in to leave a comment.