JDK 1.6.0 and IntelliJ 6.0.2, I tried...

I made an alias to my JDK 1.6.0 directory and called it "jre" under my IntelliJ 6.0.2 installation directory in an effort to see if it was possible to use JDK 1.6.0 with IntelliJ and the message returned was:

+Java Version Mismatch
The JDK version is 1.6.0
IDEA requires JDK 1.5+

I tried...

Thanks,

10 comments
Comment actions Permalink

You need to add
idea.no.jdk.check=true
to your idea.properties file.
http://blogs.jetbrains.com/idea/2006/08/running-mustang/

Bas

0
Comment actions Permalink

That worked, thank you!

Uh... is it me or is IntelliJ noticeably faster? I'm running on a

Operating System: Windows XP Professional (5.1, Build 2600) Service Pack 2 (2600.xpsp_sp2_gdr.050301-1519)
Language: English (Regional Setting: English)
System Manufacturer: Dell Computer Corporation
System Model: OptiPlex GX270
BIOS: Phoenix ROM BIOS PLUS Version 1.10 A02
Processor: Intel(R) Pentium(R) 4 CPU 2.40GHz
Memory: 2046MB RAM

I'm serious, this is a lot better.

Thanks again!

0
Comment actions Permalink

Another nice surprise the idea.exe memory usage is staying around 45,000 K on a consistent basis and not bloating up to over 120,000 K as I've seen routinely.

I've been working in IntelliJ all morning and by lunch time, it's time to stop and restart the application due to performance issues...
*
This is wonderful!*

0
Comment actions Permalink

Duplicate.

Message was edited by:
Todd

0
Comment actions Permalink

I've tried 1.6.0-b104 which is pretty close to the release build.
Running idea (#6117) on it (on Win2000, using Idea.Alloy L&F) seems to trigger
some kind of slow "smooth scrolling" when using the mouse wheel, even when
the option is disabled in the settings.

Has anyone else experienced this?


0
Comment actions Permalink

Same problem here - even with final Java 6.
If somebody from JetBrains is listening:
Should I file a Jira issue?

Taras Tielkes wrote:

I've tried 1.6.0-b104 which is pretty close to the release build.
Running idea (#6117) on it (on Win2000, using Idea.Alloy L&F) seems to
trigger some kind of slow "smooth scrolling" when using the mouse wheel,
even when the option is disabled in the settings.

Has anyone else experienced this?

0
Comment actions Permalink

Taras Tielkes wrote:

I've tried 1.6.0-b104 which is pretty close to the release build.
Running idea (#6117) on it (on Win2000, using Idea.Alloy L&F) seems to
trigger some kind of slow "smooth scrolling" when using the mouse wheel,
even when the option is disabled in the settings.

Has anyone else experienced this?


I have. I just tried 1.6.0-b105 (the first time I've used any build of
1.6) and IDEA #6117 on Linux and see exactly what you describe. It
doesn't seem to be affected by the L&F. It makes editing very
frustrating. I'm displaying my desktop on a remote X server which will
exacerbate any underlying problem (although with JDK 1.5 performance is
absolutely fine).

However, on testing with IDEA on the local display there's no "smooth
scrolling" performance problem at all. Interestingly, turning on
anti-aliasing for the editor font on the remote display doesn't make
things any slower (whereas it kills editor performance for me with JDK
1.5 and a remote display).

--
Mark Scott
mark@codebrewer.com

0
Comment actions Permalink

Hello Stephen,

Should I file a Jira issue?


Please do so, and post the JIRA link here. I will update to the final 6.0
release tomorrow, and add my comments (and CPU snapshot) to the issue.

Regards,
-tt


0
Comment actions Permalink

http://www.jetbrains.net/jira/browse/IDEA-10739

Taras Tielkes wrote:

Hello Stephen,

>> Should I file a Jira issue?


Please do so, and post the JIRA link here. I will update to the final
6.0 release tomorrow, and add my comments (and CPU snapshot) to the issue.

Regards,
-tt

0
Comment actions Permalink

There was a post on the intellij blog back in august about this issue. See my comment about the 6th one down that might give you a little more information about what is causing the issue.

On one of my work machines I still continue to have this problem and simply opening one of the "intention" popup menus or "generate" popup menus always changes the scrolling back to normal. My other work machine doesn't seem to ever have this issue with mustang.

Obviously this is not really a fix for the issue, but it might be able to point you in the right direction to find the real cause. Hope this helps.

- Gary

0

Please sign in to leave a comment.