Terminal input doesn't display for WordPress plugin project

I have PhpStorm 8.0.3 installed on my desktop and laptop which are both running Windows 8.1. On both I setup a WordPress plugin project with project files stored in a plugin directory within the WAMP server directory (...\Documents\wamp\www\wordpress\wp-content\plugins\wppluginrets). On the laptop any input I enter in the PhpStorm Terminal appears with a white font which is impossible to read with the white background. The prompt appears normally with a black font. For non-WordPress plugin projects where the files are stored in a subdirectory of PhpstormProjects Terminal input displays in black. Terminal input also displays correctly for both kinds of projects on my desktop. Any ideas why Terminal input display is an issue on my laptop for my WordPress plugin project or how to fix this? I have exited PhpStorm and rebooted my laptop twice with no success. I found where to change font colors for the editor, but not the terminal.

2 comments
Comment actions Permalink

Hi there,

I found where to change font colors for the editor, but not the terminal

Same place -- "Settings (Preferences on Mac) | Editor | Colors & Fonts | Console Colors"

Although I'm not sure why it will be different on the same computer but in different projects. Possibly some other settings affecting it (but I personally have no clue what it may be)

0
Comment actions Permalink

Thank you, Andriy, for explaining where to change Console Colors. Unfortunately, changing the foreground color for Console User Input had no effect. I also tried changing the background color to orange. Then my input also appeared in orange which again was impossible to read.

I then tried picking a different Scheme. The color of my input still matched the background. However, when I changed back to  the default Scheme that triggered something and my input now appears in a color other than the background. Thanks again, for your help!

0

Please sign in to leave a comment.