WebStrorm 10 poor performance - any ideas on how to fix?

I just upgraded froom WebStorm 9 to WebStorm 10 on a Win 7 64 bit machine with 16 gig of memory and 6 cores and the performance is horrible.  Almost all edit / movement actions have a lag in basic operations like selecting text, mouse movement, or even scrolling thru the code.  Its like editing in slow motion and its very frustrating to say the least.

Has anyone else seen this and if yes do you have any ideas on how to improve the performance?

I only use it for editing our own JS code, not linked to other libraries or platforms, so is there stuff that can be disabled that it may be evaluating?

Thanks for any ideas

6 comments
Comment actions Permalink

Please try File | Invalidate Caches and restart.
If issue remains, please capture the CPU snapshot:
start the snapshot, type something, make some actions in IDE(at least for a minute), then stop the snapshot: https://intellij-support.jetbrains.com/entries/29983118 .
You can attach it here or to the support ticket (which is more secure): https://intellij-support.jetbrains.com/anonymous_requests/new

0
Comment actions Permalink

Liubov,
I did the Invalidate caches and it worked ok at first, but is starting to have pause issues again after a few minutes of just minimal editing.

The article you reference for creating a CPU snapshot says to use "Tools menu: Start CPU Usage Profiling", but there is no option on the V10 tools menu for starting a CPU Usage profile.  There are some options for V8 profiling and the Capture Memory Snapshot, but nothing for CPU snapshot.

How am I supposed to get to your CPU snapshot in V10?

Thanks

0
Comment actions Permalink

I am experiencing the same issues. After awhile, the IDE gets bogged down on a relatively small project - I only have one HTML and one TypeScript file open (though the typescript file does have 6 definition files included). It's fine at first, but gets slower and slower and eventually pops up about being out of memory. This is on a Windows 10 system with 16 gb of memory - I didn't have these issues in version 9.

0
Comment actions Permalink

Please create a support request on this, the CPU snapshot can contain secured info: https://intellij-support.jetbrains.com/anonymous_requests/new

0
Comment actions Permalink

Jetbrains still has no answer to this issue which has a number of posts in the forum about the poor performance issue.

Looking thru them the common thing seems to be if you have a project of any size the performance problem shows up pretty quickly.

Hopefully they can do something about it, cause WS 10 in its current state is completely unusable for our projects.

0
Comment actions Permalink

Just wanted to chime in and say that I'm having this issue too. Doesn't seem to be isolated to a single project either.

0

Please sign in to leave a comment.