JavaDoc Comments My Way?

Hi,

I dislike all the unbidden auto-typing the editor does for me. For example, I type "/**" and a JavaDoc comment stub appears. I dislike this intensely, in part because I cannot stand the astersisks on the left-hand border. Similarly, when I type ]]> within a JavaDoc comment (one without left-hand stars) the prevailing indent is ignored and instead a fixed one-space indent from the column at which the slash in the opening "/**" appears is used.

I turned off the "Settings | Editor | Behavior | JavaDoc Stub After /*" option, but it's still inserting this stuff when I type "/*]]>".

In general, I really dislike this kind of non-requested assistance and auto-typing. Is there a way I can disable it all?


Thanks.

Randall Schulz

7 comments
Comment actions Permalink

Hello Randall,

RS> I dislike all the unbidden auto-typing the editor does for me. For
RS> example, I type "/**" and a JavaDoc comment stub appears. I RS> dislike this intensely, in part because I cannot stand the RS> astersisks on the left-hand border. RS> RS> Similarly, when I type within a JavaDoc comment (one RS> without left-hand stars) the prevailing indent is ignored and RS> instead a fixed one-space indent from the column at which the slash RS> in the opening "/**" appears is used. RS> RS> I turned off the "Settings | Editor | Behavior | JavaDoc Stub After RS> /**" option, but it's still inserting this stuff when I type RS> "/**". RS> RS> In general, I really dislike this kind of non-requested assistance RS>]]> and auto-typing. Is there a way I can disable it all?

You can't disable it, but you can configure it. Code Style | JavaDoc |
Enable leading asterisks.

--
Dmitry Jemerov
Software Developer
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Dmitry,

Thanks. That's a bit of an improvement, though I still don't have as much control as I'd like.

I changed all the leading spaces shown in the preview to tabs, but the changes were ignored and discarded.

RRS

0
Comment actions Permalink

Hello Randall,

RS> I changed all the leading spaces shown in the preview to tabs, but
RS> the changes were ignored and discarded.

The preview is not the place to make the changes to settings - rather, it's
a place where you can try out the new settings on some code fragments that
are not part of the default preview text.

--
Dmitry Jemerov
Software Developer
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

HI,

All the busy-body behavior in JavaDoc comments is intolerable to me, since it badly slows me down to have to go back and undo it all.

So I tried to turn it off by unselecting the "Enable JavaDoc Formatting" in Settings | Global Code Style | JavaDoc (and yes, I am using the global formatting styles in the Project Code Style settings page).

Sadly, the editor is still adding single-space indent to the prevailing indent of the JavDoc comment. Futhermore, it's actually removing the blank lines I put between the end (close brace) of the previous method and the start of the JavaDoc comment for the next method.

Is there some way I can stop all this? It drives me nuts.

Assisted editing is nice, but not if it won't accommodate my preferences.

]]>

Randall Schulz

0
Comment actions Permalink

OK. That's not where to change the formatting.

Where do I change it?

]]>

RRS

0
Comment actions Permalink

Hello Randall,

RS> OK. That's not where to change the formatting.
RS>
RS> Where do]]> I change it?

In all the tabs of the dialog. In particular, to change spaces to tabs, check
the "Use tab character" checkbox in the "General" tab.

--
Dmitry Jemerov
Software Developer
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

I'm not sure what you mean by "in all the tabs of the dialog." At the moment, I'm only talking about formatting that's being imposed in and around JavaDoc comments. And there's only one "Use tab character" check-box, in the General tab, and I long ago enabled that.

The problem is that JavaDoc formatting appears to insists on an indent of one space relative to the prevailing indent. It won't even follow my example after I've fixed that on a given line.

And what about the deleting of blank lines above the "/**" line? How do I stop that? I've set the number of blank lines "Around method" to two, but when I type a JavaDoc comment the two or three lines I typed (I group methods and put three blanks between groups) are discarded in favor of a single line.

RRS

0

Please sign in to leave a comment.