Ant issues

First, should I go ahead and add the following bug to the tracker?

When adding the following lines to the top of our build file to include some external entities it caused problems with the "Edit Source" feature in the Ant view. If I right-clicked on the target in the Ant view and selected "Edit Source" from the popup menu, the cursor was not moved to the start of the target definition in the editor. Remove the entity definitions from the top of the build file and the problem goes away. It also didn't resolve any of the property definitions included in the external files, but that's nothing new. That has never worked to the best of my knowledge in any build so far. It's a feature I'd love to see in the Ant plugin since it really is annoying to see all the errors in the editor when we have parent/child relationships between our build files in larger projects. If somebody knows a workaround to this problem, other than disabling error checking, I'd love to hear about it.

<!DOCTYPE project [
ENTITY xdoclet-classpath SYSTEM "file:../../etc/buildfragments/xdoclet-classpath.xml"
ENTITY compile-classpath SYSTEM "file:../../etc/buildfragments/compile-classpath.xml"
ENTITY manifest-extension SYSTEM "file:../../etc/buildfragments/manifest-extenstion.xml"
]>

UK

1 comment

Hi,

Property support should work even with included xmls. You can looks through
the closed tracker SCRs which may help you to recognize the problem.

We're also aware of "Edit Source" not working with included xmls. There's
definitely an open SCR in tracker.

--
Best regards,
Mike Aizatsky.
-


JetBrains, Inc / IntelliJ Software
http://www.intellij.com
"Develop with pleasure!"


0

Please sign in to leave a comment.