How to get around "windows cannot find chrome" when debugging JS (with no Google Chrome installed)

I have FF (v.35), Opera (v.12), and IE (v.11) installed on my Win 7 x64 PC and wanted to debug a (locally stored) HTML file that loads a JS script.

After adding the file to a new project, I went to File > Settings > Tools > Web Browsers and unticked the web browsers that I do not have installed.

So those settings now looks like this:

webstorm_web_browsers_settings.png


After that I went to "Edit Configurations" and added the HTML file that I wanted to debug, as shown below:

webstorm_edit_configurations.png

(note that the HTML file is not empty, even though it is named that way)

Now if I click on the 'Debug (default)' button, I get these messages that Windows has a problem finding chrome and WebStorm is waiting for a connection from the Chrome plugin:

webstorm_error_messages.png

On another hand, if I click on the 'Run (default)' button it opens the page in Firefox as expected.

I am either doing something wrong or have something misconfigured.

How can I tell WebStorm not to use Chrome for debugging?

TIA,

1 comment
Comment actions Permalink

you can't use JavaScript Debug Run configuration to debug in browsers  other than Chrome (actually you can only choose between 'Chrome' and  'Default' there, and, if 'Default' is not Chrome (Chromium, Dartium or  any other Chrome-based browser), WebStorm will try using Chrome.


To debug in FireFox 33+, you have to enable Remote debugging in Firefox  and then use the Firefox Remote run configuration. Please follow steps  from the comment: https://youtrack.jetbrains.com/issue/WEB-13801#comment=27-904044.
Unfortunately, this new debugging support only works in FireFox 33-35 - it doesn't currently work for FF 36+ (https://youtrack.jetbrains.com/issue/WEB-15696). If you are using v 36 or higher, please vote for this ticket to be notified on updates.
0

Please sign in to leave a comment.