Excluded paths not honored when synchronizing

I don't want to synchronize the images folder, uploads, temp, etc. I have set up the remote paths as excluded in my deployment settings.

However, when I select "Deployment->Synch with [name of deployment target]" from the context menu on my project root, the resulting dif window shows that PHPStorm wants to download the folders that I explicitly excluded.

Further, the .idea folder is listed as being uploaded with the synch. When I try to add that to the excluded paths for deployment, PHPStorm says "Path is outside the project".

The folders are also all marked as excluded under the project settings.

I have also set up .htaccess on the remote side as excluded, and .htaccess locally as excluded. These files are also shown in the Sync dif.

Am I missing something here?

6 comments
Comment actions Permalink

Hi there,

To start with: please show screenshot of your Sync window (whole window).

0
Comment actions Permalink

(edit note: this post is not in chronological order with my reply containing screenshots. The screenshots are newer than these two posts here)

Update: I restarted PHPStorm for a different reason (added the .ignore plugin), and turned off automatic deployment on file change.

Neither of those things seem related to the synch issue (except maybe the restart?), however, when I synch now, the ignored folders are not listed -- as expected.

The only exception to that is the .idea folder.

0
Comment actions Permalink

I see two more folders that have temporary files in them, so I'll add those to my Excluded list and see if I can reproduce the original problem. If so, I'll drop some screenshots here. Thanks for the reply.

0
Comment actions Permalink

I tried adding some new folders to the exclude list, then synchronizing, and it did the same thing.

I tried to restart PHPStorm and synchronize again, and it acted the same -- my excluded folders are listed in the synchronization.

Screenshots are the dif window, then the excludes. Note the red-circled folders in the dif window are the final two entries on the exclude list.



Attachment(s):
excludes.png
foldersA.png
0
Comment actions Permalink

Activate "Hide excluded files" option (the blue funnel icon on toolbar)

0
Comment actions Permalink

Aha! Thanks very much for your reply :)

Great product, by the way. I never thought I would be able to change to an IDE from my stripped-down text editor that I had used for years. Someone talked me into trying this, and I was comfortable with the change within the first day of work, and now I couldn't imagine using that old clunky thing I used to code with!

0

Please sign in to leave a comment.