comment copying on override method

Hello,

I just now noticed that when I override methods from a superclass, I get all the comments copied into the new method as well. I dont know if this is a completely new feature (maybe I have been mostly overriding methods where the source was not available), but I find this rather annoying, as keep deleting the comments.

Is there/will there be an option to NOT have comments copied? I didnt find it so far.

2 comments


"Christian Sell" <christian.sell@netcologne.de> wrote in message
news:16008263.1047131321008.JavaMail.jrun@is.intellij.net...

Hello,

>

I just now noticed that when I override methods from a superclass, I get

all the comments copied into the new method as well. I dont know if this is
a completely new feature (maybe I have been mostly overriding methods where
the source was not available), but I find this rather annoying, as keep
deleting the comments.
>

Is there/will there be an option to NOT have comments copied? I didnt find

it so far.

Uncheck the "Copy JavaDoc" checkbox to the left of the OK button in the
dialog.


0

Uncheck the "Copy JavaDoc" checkbox to the left of the OK button in the
dialog.


In fact, I don't think this checkbox will affect copying of non-javadoc
comments. AFAIK copying non-javadoc comments is not a new behaviour. You may
submit a request if you don't like it.

--
Valentin Kipiatkov
JetBrains, Inc
http://www.intellij.com
"Develop with pleasure!"


"Chris Bartley" <intellij-idea@chrisbartley.com> wrote in message
news:b4cvfm$ot4$1@is.intellij.net...
>

"Christian Sell" <christian.sell@netcologne.de> wrote in message
news:16008263.1047131321008.JavaMail.jrun@is.intellij.net...

Hello,

>

I just now noticed that when I override methods from a superclass, I get

all the comments copied into the new method as well. I dont know if this

is

a completely new feature (maybe I have been mostly overriding methods

where

the source was not available), but I find this rather annoying, as keep
deleting the comments.
>

Is there/will there be an option to NOT have comments copied? I didnt

find

it so far.

>

Uncheck the "Copy JavaDoc" checkbox to the left of the OK button in the
dialog.

>
>


0

Please sign in to leave a comment.