Can't debug with JDK1.3.1_07 in build#695

We know that jdk1.3.1_07 is out. Unfortunately, it cann't start debug session in IDEA!

It always says 'java.lang.NoClassDefFoundError: Exception in thread "main"'! But jdk1.3.1_06 or j2sdk1.4.1_02 is ok. Anyone knows why?

5 comments

In article <31566615.1046500578441.JavaMail.javamailuser@localhost>,
biubiu@163.com says...

We know that jdk1.3.1_07 is out. Unfortunately, it cann't start debug session in IDEA!

It always says 'java.lang.NoClassDefFoundError: Exception in thread "main"'! But jdk1.3.1_06 or j2sdk1.4.1_02 is ok. Anyone knows why?

http://www.intellij.net/tracker/idea/viewSCR?publicId=9817

0

Well, from my experience, the last usable JRE 1.3.1 was version
1.3.1_04. All further had so much problems they were not usable for
real applications. I suggest you to use 1.3.1 (without a
bug-fix-version) or 1.3.1_04.

Cheers,
Tom

0

Thomas Singer wrote:

Well, from my experience, the last usable JRE 1.3.1 was version
1.3.1_04. All further had so much problems they were not usable for
real applications. I suggest you to use 1.3.1 (without a
bug-fix-version) or 1.3.1_04.

Cheers,
Tom

From mine (no swing work), 131_06 was absolutely fine for developemnt.
I haven't tried _07 though.

Edo

0

In the newer version of the jdk's 1.3.1, the classic vm is not delivered anymore.
So if you enforce classic vm option, then it produces this error message.
Deselect the option "Force classic VM(JDK1.3.x and earlier)" in Debugger Project Properties.

0

Actually in 1.3.1_07 it is delivered, but it fails to start under certain conditions.

--

Best regards,
Eugene Zhuravlev
JetBrains, Inc, http://www.intellij.com
"Develop with pleasure!"



0

Please sign in to leave a comment.