xDebug - waiting for incoming connection

Hi,
I've had xDebug working well with MAMP and Eclipse Luna, and now I'm trying to set it up with PHPStorm 8.0.3. I'm in OS X 10.10.2

I've configured everything but when I run my debug configuration, the browser opens the site, but PHPStorm doesn't stop at the breakpoints, and it shows the message 'Waiting for incoming connection with ide key 'xxxxx' where xxxxx is the number at the end of the browser page url.

Here are my config details:

In php.ini

[xdebug]
xdebug.default_enable=1
xdebug.remote_enable=1
xdebug.remote_handler=dbgp
xdebug.remote_mode=req
xdebug.remote_connect_back=1
xdebug.remote_host=localhost
xdebug.remote_port=9000
xdebug.remote_autostart=1
xdebug.remote_log="/var/tmp/xdebug.log"
zend_extension="/Applications/MAMP/bin/php/php5.6.2/lib/php/extensions/no-debug-non-zts-20131226/xdebug.so"

(I added the remote_mode and remote_connect_back params after reading up on this issue, but that hasn't helped.)

For my PHPStorm settings please see attached images.
I'm using mapping because the web application is symlinked in the htdocs folder

I've also tried zero-configuration debugging using bookmarklets, but that didn't work either.

Thanks for any suggestions.



Attachment(s):
Screen Shot 2015-04-13 at 12.56.43.png
Screen Shot 2015-04-13 at 12.56.22.png
Screen Shot 2015-04-13 at 12.55.22.png
Screen Shot 2015-04-13 at 12.55.00.png
1 comment
Comment actions Permalink

I got it working. For reference, I had to enable 'Can accept external connections' in Preferences -> Build, Execution, etc. -> Debugger

Once that was ticked, the connection to the debugger worked, and I could see that my project's server mapping wasn't correct. ( I had to set Absolute path on the server to be the same as File/Directory). All OK now.

0

Please sign in to leave a comment.