Interpreter is not defined in PHPUnit configuration pop up

Hi,

There is an issue I am trying to resolve with my configuration of PHPUnit Configuration. Run/Debug Configurations pop up window shows "Error: Interpreter is not specified or invalid". I have PHP 5.5.14 installed on my Mac and interpreter is defined under File -> Default Settings -> PHP tab. Everything I've found is that interpreter should be defined, however it is really true. I use mac and PHPStorm 8.0.3.

Does anyone have a tip or suggestion how to solve this issue?

Thank you in advance,
Max

2 comments
Comment actions Permalink

Hi there,

and interpreter is defined under File -> Default Settings -> PHP tab.

"File | Default Settings" is for setting default settings for future new projects -- it does not affect current project in any way.

For current project you have to use "File | Settings" (that's for Windows/Linux) or "PhpStorm | Preferences" on Mac.

0
Comment actions Permalink

Hi Andriy,

Thank you for really quick reply. It works now. I definitely missed difference moving from Windows to Mac OS.

Thanks

0

Please sign in to leave a comment.