debugging problems (part 2)

Can someone please help me understand how a breakpoint can be ignored.
After setting a breakpoint on a given line (ie. a System.out.println), the
breakpoint indicator shows as a solid red circle. I then use the web app,
such that I force it to go thru the code I want to break on. It executes
the System.out since I see the output to the console. Upon returning to
IDEA, I notice the solid red circle now has an "x" through it. I made sure
to do a an ant build, just prior to executing the code so I know it is up to
date.

What's difficult to figure out is, under this same version of IDEA (692), I
successfully used it to do remote debugging, albeit for a different project.
I don't know where to begin to trace this problem down. It connects to the
server ok. It just wont suspend on breakpoints.

Any ideas are appreciated...

Michael.


1 comment

Found it.

Our new javac ant task for this project didn't have debug="on".
Interestingly enough, this seems to have tripped up a few people on multiple
occasions. This would be an ideal candidate for inclusion in a FAQ. I
would go so far as to update the Jetbrains motto:

Develop with Pleasure...make sure debug="on"!

:)




"Michael Morett" <michaelmorett@yahoo.com> wrote in message
news:b3j3bs$ksp$1@is.intellij.net...

Can someone please help me understand how a breakpoint can be ignored.
After setting a breakpoint on a given line (ie. a System.out.println), the
breakpoint indicator shows as a solid red circle. I then use the web app,
such that I force it to go thru the code I want to break on. It executes
the System.out since I see the output to the console. Upon returning to
IDEA, I notice the solid red circle now has an "x" through it. I made

sure

to do a an ant build, just prior to executing the code so I know it is up

to

date.

>

What's difficult to figure out is, under this same version of IDEA (692),

I

successfully used it to do remote debugging, albeit for a different

project.

I don't know where to begin to trace this problem down. It connects to

the

server ok. It just wont suspend on breakpoints.

>

Any ideas are appreciated...

>

Michael.

>
>


0

Please sign in to leave a comment.