run phpstorm without built-in server

I have some php script when i run into localhost\myproject it work fine, but when i run at localhost:(port)\myproject it doesn't work. how can i fix it or how do i disable the built in web server?

6 comments
Comment actions Permalink

Hi there,

You cannot disable it ... but you can tell PhpStorm to use your own server.

For that -- define and properly configure a Deployment entry ("Settings (Preferences on Mac) | Build, Execution, Deployment | Deployment") and mark it as Default for this project. Now IDE will use URL provided here instead of the URL of built-in web server.

0
Comment actions Permalink

I can't find setting that you mean, are you using 8.02? i see that setting before but when i use 8.03 version i can't setting it anymore.

0
Comment actions Permalink

I'm suing 8.0.3.

8.0.2 should be exactly the same -- as it's the first version that got this new Settings sctructure.

In any case: please post screenshots of what you have got there and what you cannot find.

0
Comment actions Permalink

There's no Deployment option and i can't find "mark it as Default for this project". I only have Coverage, Debugger, and Path Variable Setting.



Attachment(s):
2015-04-09_17-59-45.gif
0
Comment actions Permalink

Make sure that "Remote Hosts Access" plugin is enabled.

0
Comment actions Permalink

it work. thank you :D

0

Please sign in to leave a comment.