Ctrl+w doesn't close tab; closes Project window (Eclipse keymapping)

I set PHPStorm to use Eclipse keymapping, and when I have an active tab open and hit Ctrl+w, it always closes the Project window (tab?) on the left and never any open tabs. I want it to close whatever is the open/focused/last-focused tab like Eclipse.

I checked Settings > Appearance & Behavior > Keymap, searched for "close tab", Ctrl+w for Close Active Tab, and Ctrl+Shift+w for Close All under Editor Tabs.

Any idea what's going on?

5 comments
Comment actions Permalink

Edit: If I right-click a tab, Close says Ctrl+F4, and Close All says Ctrl+Shift+F4; I don't know how to ACTUALLY get the Keymap settings to stick.

0
Comment actions Permalink

Hi there,

The correct action for closing current editor tab (in Keymap) is : Main Menu > Window > Editor Tabs > Close

I don't know how to ACTUALLY get the Keymap settings to stick

Editing bundled keymap is not allowed -- make sure to create your own copy first ("Copy" button) and then modify it as you wish (right click on desired action and choose "Add Keyboard Shortcut")

Edit: If I right-click a tab, Close says Ctrl+F4, and Close All says Ctrl+Shift+F4;

Keymap screen has a search button (next to search by name input field) that allows you to find action by its keyboard shortcut.

0
Comment actions Permalink

Well, PHPStorm is doing it wrong then, because Ctrl+W in Eclipse closes the current open file tab (where your code is), not the Project tab, but PHPStorm closes the Project tab, and assigns Ctrl+W to Window > Active Tool Window > Close Active Tab (which isn't really useful).

I'm not sure what you mean by 'bundled' keymap, but I just deleted the incorrect mappings and assigned Ctrl+W to Window > Editor Tabs > Close. I don't understand why the rearrangement or misalignment.

0
Comment actions Permalink

https://youtrack.jetbrains.com/issue/IDEA-125657

I'm not sure what you mean by 'bundled' keymap

"bundled" means supplied/provided by default an dnot the one that you need to install/create separately.

0
Comment actions Permalink
  1. Open Settings by hitting Ctrl+Alt+S
  2. Click: Keymap
  3. Search for: Close
  4. Under Main menu > Window > Editor Tabs, find Close.
  5. Right-click and click Remove Ctrl+F4.
  6. Right click and click Add Keyboard Shortcut
  7. Add your new custom Keyboard Shortcut.

IntelliJ will tell you if the shortcut clashes with another shortcut performing a different action.

0

Please sign in to leave a comment.