Can't get multiple cursors to work on Linux Mint 17

I'm following the instructions gven in your webstorm 8 youtube video: https://www.youtube.com/watch?v=JBkGOPR3-nA

Holding alt and selecting the position for curosoirs does not work nor does alt + slide down.

According to the video it should work with Linux. Mint 17 is the same as Ubuntu 14 LTS, just a different UI.

using Storm 8.02

Many thanks !

9 comments
Comment actions Permalink

Hi there,

Please check that Alt+Click is not assigned to some system-wide action (e.g. to drag windows around). AFAIK it's the case on Ubuntu (at least in the past)

0
Comment actions Permalink

yes alt + click moves the window around.

Ok - I have gone to the key map and "Add or Remove Caret"  is Alt+Button1 +click

What is button 1 ??  you mean number 1 on the key board - that does not work either.

Also there is no obvious way of changing it to something else. All I can do is remove the key map. Lastly "add mouse short cut" does not do anything.

I'm sure it is me ... but I don't follow what the docs say.

Many thanks  !

0
Comment actions Permalink
What is button 1 ??

Mouse left button.

Also there is no obvious way of changing it to something else.

You removing existing .. then adding new shortcut... -- it works this way.


In any case: please read comments here: https://youtrack.jetbrains.com/issue/IDEA-122197

AFAIK Alt+J should also work (depends on keymap and context, actually)

0
Comment actions Permalink

Hi Andriy -
I still can't get thi to work the way it should.  I have seen in a Laravel tutorial that you can place your cursor on four separate points and then type in the text you want in those four points. The text will be entered without affecting the rest of the text on any of the lines.

I have managed to get the mouse key map to provide me with multiple cursors on Linux Mint - good. However, now when I place my cursor on four points, two things happen:

1) the cursors on point 2 and 3 will dissappear.
2) the cursor on point 1 and 4 will be present with the text in between highlighted in yellow - see screen shot.
3) If I now type some text the lines between point 1 and 4 are immediatley deleted and the text appears on line 1.  see screen shot.

I must be doing something wrong.

any ideas - Many Thanks !



Attachment(s):
Screenshot from 2015-03-20 11:06:54.png
Screenshot from 2015-03-20 10:57:45.png
0
Comment actions Permalink

Well ... I'm not using Linux myself .. so it's hard for me to give you definite answer...

You seems to be using some custom (non Default or Darcula) editor scheme as I do not remember such yellow background color in any of the contexts (except current line .. but you seems to have gray color for it).

Based on both screenshots (2 cursors are still present on both of them) -- my guess that that yellow background is just an ordinary selection .. which (naturally) gets deleted when you type anything over it.

So the question is -- why cursors #2 and #3 were removed and selection was added there.

Most likely it's related to the actions (shortcuts) you are using when adding multiple cursors.

Can you describe what shortcuts you are using (and check in "Settings | Keymap" to what action they assigned (there is special button which allows you to search by shortcut)).

0
Comment actions Permalink

Thanks for your rapid reply - ok, following your advice I am trying to serch for Shift+Button1 Click however, new problem, the search by key strokes tool will not accept a "Shift" under First stroke.

0
Comment actions Permalink
new problem, the search by key strokes tool will not accept a "Shift" under First stroke

It looks like search does not accept mouse -- only keyboard. And .. since there will be Shift (modificator key) on it's own (as mouse clicks are not accepted) .. it does not accept it either (it needs to be modificator plus something, e.g. stuff like Shift+A or similar).

In any case: having Shift+Button1 as a shortcut seems to be the problem here -- it's standard for "start/stop selection here" and it seems to be having priority over multi cursor -- not sure but that's how it looks like here.

Try assigning new shortcut without it (without Shift, e.g. Ctrl+Alt+Button1).. or with some another modificator as well (e.g. Ctrl+Shift+Button1)

0
Comment actions Permalink

Yeah !!!! In the end I had to reassign one of the main menu key bindings as it would not allow Shift +G + Click or any other combination involving a letter.

Many thanks !! this will save me big Time !!

0
Comment actions Permalink

It's easy with KDE.
You can disable global shortcuts per window or per Application.

Following path may have other words.. because I don't use english Window-Menu, I have it translated. Sense should show which buttons are mean:


Right-Click at your PhpStorm Titlebar ⇒ Additional Actions ⇒ special Settings for this Programm (or special settings for this Window) ⇒ Last Tab (Layout) ⇒ Global Keys ⇒ force ⇒ yes 

Downside is, that no other global shortcuts (like CTRL-TAB) work if mouse over phpstorm-window.

0

Please sign in to leave a comment.